New Zealand Operators - OTP Affected
Incident Report for Spendl
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 10:41 UTC
Investigating
We kindly inform you that there is a technical issue with all New Zealand phone operators.

Unfortunately, we do not know how long it takes to solve it, our experience shows that it usually takes about a month.

We will update immediately as soon as we get any updates.
Posted Feb 15, 2021 - 17:15 UTC