Apple Pay Onboarding Interruption
Incident Report for Spendl
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2020 - 05:59 UTC
Investigating
We are currently investigating this issue.
Posted Sep 25, 2020 - 16:53 UTC
This incident affects: Virtual Cards.