Loading Card with Lightning Is Down
Incident Report for Spendl
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 14:11 UTC
Identified
Currently, Lightning Loads are no available.

We are working to solve this issue.
Posted Apr 01, 2021 - 17:57 UTC