Service Interruption
Incident Report for Spendl
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 16:27 UTC
Investigating
card unlock and card loads might be affected.

We are currently working to solve this issue.
Posted Feb 15, 2021 - 16:42 UTC
This incident affected: API.